re = /(?!href)\b[\w]+=[\w" :]+/m
str = '<table id="this is id">
<tr id="this tr id">
<a href="https://www.w3schools.com">Visit W3Schools.com!</a>
<div id="this is div id"><span id="div Class:a">this is span text</span></div>
</tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end