$re = '/([a-z])(?=[a-z]*\1)/';
$str = 'data
pattern
alice
bob
zdim
avery
paragraph
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);