import Foundation
let pattern = #"-(\S+)\h+(.*?(?=\h+-|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Insert Post -title Some PostTitle -category 2 -date-posted 2013-02:02 10:10:10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)