$re = '/([a-zA-z]+|[^a-zA-z]+)/i';
$str = 'Hello12$th\'ere!^@4';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;