package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<bus>\d+)\s(?P<directions>.*?)-(?P<zone>[^\-]+)\s(?P<time>\d+)`)
var str = `150 H.S.London-lon3 11£150 H.S.London-lon3 16£150 H.S.London-lon3 120
400 Airport Luton-ptr5 12£400 Airport Luton-ptr5 15£400 Airport Luton-ptr5 17
005 Plaza-cata-md6 08£005 Plaza-cata-md6 012£005 Plaza-cata-md6 18
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}