re = /\^([a-zA-Z0-9](?:(?:[a-zA-Z0-9-]\*|(?<!-)\.(?![-.]))\*[a-zA-Z0-9]\+)?)$ /
str = '0004F301610F'
# Print the match result
str.match(re) do |match|
puts match.to_s
end