re = /^(?:.(?=.+?(.\1?$)))+?\K..?(?=\1$)|^..?/m
str = 'Hello
world
merged
hi
I
a
ab
abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end