use strict;
my $str = '##! PostgreSQL: \'{"b":2}\'::jsonb <@ \'{"a":1, "b":2}\'::jsonb
##! PostgreSQL: \'{"b":2}\'::jsonb @> \'{"a":1, "b":2}\'::jsonb
##! PostgreSQL: \'{"b":2}\'::jsonb @ \'{"a":1, "b":2}\'::jsonb
##! PostgreSQL: \'{"b":2}\'::jsonb < \'{"a":1, "b":2}\'::jsonb
##! PostgreSQL: \'{"b":2}\'::jsonb > \'{"a":1, "b":2}\'::jsonb
##! SQLite: \'{"a":2,"c":[4,5,{"f":7}]}\' -> \'$.c[2].f\' = 7
##! SQLite: \'{"a":2,"c":[4,5,{"f":7}]}\' <- \'$.c[2].f\' = 7
##! SQLite: \'{"a":2,"c":[4,5,{"f":7}]}\' < \'$.c[2].f\' = 7
##! SQLite: \'{"a":2,"c":[4,5,{"f":7}]}\' > \'$.c[2].f\' = 7
##! MySQL: json_extract(\'{"id": 14, "name": "Aztalan"}\', \'$.name\') = \'Aztalan\'';
my $regex = qr#[\]\}][\"'`].*::.*jsonb.*[<>@]+.*[\]\}][\"'`].*::.*jsonb|[\"'`][\[\{].*[\]\}][\"'`].*[\-<>]+.*[\"'`]\$.*[\"'`]|json_extract.*\(.*\)#mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}