$re = '/^[a-z]+(?:\.[a-z]+)?$/im';
$str = 'a
.aa
a.
a.a
aaa.aaa
aaa.aaa.a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);