import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\babc=(.*?)(?=\\|\\||$)";
final String string = "xyz=abcdef|abcdef||abc=123456|123456||cat=dog|dog||foo=bar|bar||\n"
+ "xyz=abcdef|abcdef||abc=123456|123456\n"
+ "xyz=abcdef|abcdef||abc=123456|123456||\n"
+ "abc=123456|123456||xyz=abcdef|abcdef||";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}