// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:[^\\"]*+|\\.)*+"#).unwrap();
let string = "{
\"entry\": {
\"_version\": 1,
\"locale\": \"en-us\",
\"uid\": \"blt8e1d2bd915a28bbd\",
\"ACL\": {
},
\"_in_progress\": false,
\"accolades\": null,
\"active\": true,
\"additionalhours\": null,
\"agenttext\": \"Eclectic\",
\"alternativerestaurants\": null,
\"availableinice\": true,
\"averageprice\": \"37.26\",
\"bookableonline\": true,
\"bookingdestinationurl\": \"https://www.sevenrooms.com/reservations/tomsurbannyny\",
\"category\": \"restaurant\",
\"chefs\": null,
\"contenttype\": \"restaurant\",
\"corporatesortorder\": \"9\",
\"created_at\": \"2022-10-25T14:04:31.079Z\",
\"created_by\": \"blta81f9191e2060891\",
\"cuisine\": \"MGM:corporate/dining/type-of-cuisine/american\",
\"cuisinename\": \"American\",
\"dailyhours\": {
\"sunday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"1:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"monday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"1:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"tuesday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"1:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"wednesday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"1:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"thursday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"1:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"friday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"2:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"saturday\": {
\"opening1\": \"8:00 AM\",
\"closing1\": \"2:00 AM\",
\"opening2\": null,
\"closing2\": null,
\"hourstype\": \"custom\"
},
\"temporaryclosed\": false
},
\"defaultnumberofguests\": \"2\",
\"descriptions\": {
\"tagline\": \"Drink. Eat. Screen.\",
\"secondary\": null,
\"overview\": \"At Tom's Urban your game is always on! Cheer on your team with your favorite draft beer in our iconic two-handed 40oz stein or indulge in some of our favorites like Deep Dish Nachos or Tom's Famous Prime Rib Dip. Join us to catch the game or get the party started and stay for our live entertainment every Friday and Saturday night until 2am!\",
\"short\": \"At Tom's Urban your game is always on! Cheer for your team on our patio or inside and enjoy your favorite draft beer in our iconic two-handed 40oz stein. \",
\"long\": \"At Tom's Urban your game is always on! Cheer for your team on our patio or inside and enjoy your favorite draft beer in our iconic two-handed 40oz stein. \",
\"appcard\": \"Tom's Urban literally has something for everybody with its unique and eclectic blend of the world's favorite street foods.\"
},
\"detailpagebrandurl\": \"https://newyorknewyork.mgmresorts.com/en/restaurants/toms-urban.html\",
\"detailpagecorpurl\": \"https://www.mgmresorts.com/en/restaurants/new-york-new-york/toms-urban.html\",
\"diningexclusiveaccess\": false,
\"disclaimer\": null,
\"dresscode\": \"Casual\",
\"emailcontactinfo\": null,
\"exceptionalhours\": null,
\"externalmenuurl\": \"https://www.mgmresorts.com/menu/tomsurban\",
\"externalwebsite\": {
\"title\": \"Website\",
\"url\": \"https://tomswatchbar.com/\"
},
\"groupreservationinfo\": null,
\"images\": {
\"overview\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-exterior-view-with-sign.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Exterior view of Tom's Urban showing the sign.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"logo\": {
\"url\": \"/content/dam/MGM/new-york-new-york/website-graphics/icons/single/icon-restaurants.svg\",
\"metadata\": null
},
\"tile\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-exterior-view-with-sign.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Exterior view of Tom's Urban showing the sign.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"region\": null,
\"gallery\": null,
\"unifiedgallery\": [
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/architecture/new-york-new-york-dining-toms-urban-south-side-patio.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Seating on the south side patio of Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"cs6d0df36b2a7b519d\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"csb5bf4725b8e4fb67\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/architecture/new-york-new-york-dining-toms-urban-bar-and-patio.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Bar seating near the patio of Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"csbadcb721dc872c87\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cs115ce8886c2df1cb\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/new-york-new-york-dining-toms-urban-punch-bowl.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Share a punch bowl at Tom's Urban with your friends!\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"csa770eac48e017b75\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cs719c85c4f6f7fa56\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-beer-and-burger.tif\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Beer stein with burger and fries from Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"csb150575367f82d45\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cs9577a057c397e4d5\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-beer-stein.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Souvenier beer stein available to purchase.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"cs456f7012a7d02da1\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"csf97d5486c3954a0a\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-prime-rib-sandwich.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Shaved prime rib, havarti, horseradish cream, brioche roll.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"cs3730d520c0ff73b5\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cs02ff2cf1c516cc51\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-deep-dish-nachos.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Layers of tortilla chips, southwest queso, pico de gallo, jalapeños, guacamole & sour cream, Adobo chicken.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"csda43fa3d098b8460\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"csa2d7c744e0254f13\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-buffalo-wings.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Served with carrots, celery & choice of ranch or blue cheese.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"csf3580cad1aa86c4d\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cs66dc51a908818542\"
}
},
{
\"type\": \"image\",
\"reference\": [
{
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/food-and-drink/new-york-new-york-dining-toms-urban-party-starter-cocktail-red-edition.jpg\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"A double dose of our Urban Margarita with hibiscus, bombed with a Red Bull® Red Edition.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
},
\"_metadata\": {
\"uid\": \"cs9f69056d7fd37143\"
}
}
],
\"title\": null,
\"caption\": null,
\"placeholderimage\": null,
\"hlsmultiratestreamurl\": null,
\"_metadata\": {
\"uid\": \"cse127c8e875a9edb6\"
}
}
],
\"appcard\": null,
\"casionevent\": null,
\"poolmap\": null,
\"logowithoutbackground\": null,
\"gallerywithcaption\": null,
\"videoswithcaptions\": null,
\"collapsedcolorvectorlogo\": null,
\"colorvectorlogo\": null,
\"bwbitmaplogo\": null,
\"colorbitmaplogo\": null
},
\"issevenroomsrestaurant\": true,
\"location\": {
\"latitude\": \"36.1029312326\",
\"longitude\": \"-115.1738485694\",
\"description\": \"Located across from the Sports Book near the Village Street Eateries\",
\"address\": null,
\"directions\": [
{
\"title\": \"South Garage \",
\"directions\": \"Take the escalator to Casino Floor, and then take the carpeted walking path located across from the front desk. This path will take you around on the outskirts of the Casino floor. You will pass Stupidiotic, Swatch, I LOVE NYNY. Tom\\u2019s Urban will be located across from the Sports Book. \",
\"_metadata\": {
\"uid\": \"csb0e5fad715a373c7\"
}
},
{
\"title\": \"North Garage \",
\"directions\": \"Take the parking garage hallway towards the Big Apple Coaster and Arcade. Pass Nathans on your left and take the escalator on the left down to the Casino Level, and then take the tile walking path to the left. This path will lead you towards Bar At Times Square. Keep walking straight towards 48th & Crepe, Tom\\u2019s Urban will be located across from the Sports Book.\",
\"_metadata\": {
\"uid\": \"cs8c4b8e0258e457b4\"
}
},
{
\"title\": \"Front Desk \",
\"directions\": \"If you are facing the Front Desk, go right towards the Century Elevators. Take the tile path towards Bar At Time\\u2019s Square. Keep walking straight towards 48th & Crepe; Tom\\u2019s Urban will be located across from the Sports Book.\",
\"_metadata\": {
\"uid\": \"cs71d51899d4c51a6e\"
}
}
],
\"appleplaceid\": null,
\"googleplaceid\": null,
\"mapimage\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/new-york-new-york-toms-urban-restaurant-dining-room.tif\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"From signature dishes such as the Slopper and Asian Crispy Duck Wings, to America's favorite streets food like burgers, buffalo wings, sandwiches, and more, there's something for everyone.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"inmarketgeolocation\": null
},
\"maxpartysize\": \"12\",
\"menucategories\": null,
\"menuhighlights\": [
{
\"name\": \"Xiangxiang Crispy Duck wings\",
\"description\": \"4 large drumsticks, hoisin glaze, Asian peanut slaw.\",
\"image\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/new-york-new-york-toms-urban-duck-wings.tif\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Enjoy duck wings at Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"_metadata\": {
\"uid\": \"csc8cd62923e35ba1a\"
}
},
{
\"name\": \"Xiangxiang Crispy Duck wings\",
\"description\": \"4 large drumsticks, hoisin glaze, Asian peanut slaw.\",
\"image\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/new-york-new-york-toms-urban-duck-wings.tif\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Enjoy duck wings at Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"_metadata\": {
\"uid\": \"cs13cb05ee008bd74b\"
}
},
{
\"name\": \"Xiangxiang Crispy Duck wings\",
\"description\": \"4 large drumsticks, hoisin glaze, Asian peanut slaw.\",
\"image\": {
\"url\": \"/content/dam/MGM/new-york-new-york/dining/toms-urban/new-york-new-york-toms-urban-duck-wings.tif\",
\"metadata\": {
\"width\": \"2880\",
\"description\": \"Enjoy duck wings at Tom's Urban.\",
\"height\": \"1600\",
\"relativefocalpointx\": null,
\"relativefocalpointy\": null,
\"pixelfocalpointx\": null
}
},
\"_metadata\": {
\"uid\": \"cs3f5ef8c0802211c2\"
}
}
],
\"mobileorderingurl\": null,
\"multiproppriority\": \"2\",
\"name\": \"Tom's Urban\",
\"path\": \"/content/ccm/en/properties/dc00e77f-d6bb-4dd7-a8ea-dc33ee9675ad/restaurants/b11f9e50-da81-40ae-9590-75d669251649\",
\"phonenumbers\": [
{
\"description\": \"Reservations\",
\"number\": \"702.740.6766\",
\"default\": true,
\"_metadata\": {
\"uid\": \"cs4a676028142d0901\"
}
},
{
\"description\": \"Group Dining\",
\"number\": \"702.740.6183\",
\"default\": false,
\"_metadata\": {
\"uid\": \"cs5a19fc20d70a3fd8\"
}
}
],
\"pricerange\": \"$\",
\"priority\": \"2\",
\"propertyid\": \"dc00e77f-d6bb-4dd7-a8ea-dc33ee9675ad\",
\"propertyname\": \"New York-New York Hotel & Casino\",
\"propertyshortname\": \"New York-New York\",
\"reopendate\": null,
\"restaurantid\": \"b11f9e50-da81-40ae-9590-75d669251649\",
\"restauranttags\": [
\"MGM:corporate/dining/meal/lunch\",
\"MGM:corporate/homepage\",
\"MGM:corporate/dining/type-of-cuisine/american\",
\"MGM:corporate/dining/happy-hour\",
\"MGM:corporate/dining/type-of-cuisine/tapas\",
\"MGM:corporate/people/groups/family\",
\"MGM:corporate/dining/meal/breakfast\",
\"MGM:corporate/dining/group-dining\",
\"MGM:corporate/dining/meal/dinner\",
\"MGM:corporate/dining/restaurant-type/casual-dining\",
\"MGM:corporate/dining\",
\"MGM:sites/mlife-com\",
\"MGM:corporate/dining/meal/brunch\",
\"MGM:corporate/price/less\",
\"MGM:mgm-resorts/restaurants\",
\"MGM:corporate/dining/meal/late-night\"
],
\"rsvipcode\": \"158191\",
\"socialnetworks\": [
{
\"network\": \"fb\",
\"title\": \"Facebook\",
\"image\": null,
\"url\": \"http://www.facebook.com/tomsurbanlasvegas\",
\"_metadata\": {
\"uid\": \"cs02e3d182f24ea606\"
}
},
{
\"network\": \"tw\",
\"title\": \"Twitter\",
\"image\": null,
\"url\": \"http://www.twitter.com/tomsurbanlv\",
\"_metadata\": {
\"uid\": \"cs5170de755f2f5ab6\"
}
},
{
\"network\": \"ig\",
\"title\": \"Instagram\",
\"image\": null,
\"url\": \"http://www.instagram.com/tomsurbanlv\",
\"_metadata\": {
\"uid\": \"cse973af76b7b48982\"
}
}
],
\"socialsharing\": {
\"title\": null,
\"description\": null,
\"image\": null,
\"channels\": null,
\"propertytwitterhandle\": null,
\"twitterhandle\": null,
\"destinationurl\": null
},
\"sommeliers\": null,
\"tags\": [
],
\"tileenabled\": true,
\"title\": \"Tom's Urban\",
\"updated_at\": \"2022-10-25T14:04:31.079Z\",
\"updated_by\": \"blta81f9191e2060891\",
\"urgentmessagebanner\": null,
\"url\": \"/tom's-urban\",
\"venueinfo\": null,
\"video\": null,
\"viewableonline\": true,
\"virtualtoururl\": null,
\"publish_details\": {
\"environment\": \"blt6d41405616d06709\",
\"locale\": \"en-us\",
\"time\": \"2022-10-25T14:04:31.581Z\",
\"user\": \"blta81f9191e2060891\"
}
}
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}