const regex = /^([A-Z][a-z]*(\s+[A-Z][a-z]*))$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Z][a-z]*(\\s+[A-Z][a-z]*))$', '')
const str = `Desk Desk`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}