$re = '/(?<=[:,])[^;,]+/';
$str = '1454974419:1234;1454974448:3255,2255,66789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);