$re = '/^(\d{2,})?:?(\d{2}):(\d{2}\.?\d*)$/m';
$str = '11:22:33
11:22:33.444
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);