package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{\{([a-zA-Z_][a-zA-Z_0-9]*)\}\}|\{%%\}="([^"]+)"|\{%((?:[^%]|%[^\}])+)%\}|([^\{]+)`)
var str = `{%
function check(a, b) {
if ($object[a] && (b === undefined || $object[b])) {
$write("checked");
}
}
%}
<tr>
<td>{{name}}</td>
<td>{{description}}</td>
<td><input type="checkbox" {%%}="check('load');"></td>
<td><input type="checkbox" {%%}="check('load', 'test');"></td>
<td><input type="checkbox" {%%}="check('doc');"></td>
</tr>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}