#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{2}.\d{2}.\d{4})"
Local $sString = "Der Hund wurde am 01.01.2016 geboren (AB)<br>" & @CRLF & _
"Am 05.06.2014 wurde ein anderer Hund geboren (XY) <br>" & @CRLF & _
"01.01.2016 ist der Tag der Tage, es war Neujahr (SI)<br>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")