package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d-a]+`)
var str = `0987654321ab...`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}