$re = '/^(?!.*\.pdf).*$/m';
$str = 'path/file.jpg
path/file.png
path/file.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);