package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)`)
var str = `[1231][123][1231]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}