re = /\B@[^@]?\w*(?!.*\B@[^@]?\w*)/mi
str = 'hello hi @why helo @blow but @name
hello hi @why helo @blow but name@name
@blow but not know how to resolve this'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end