$re = '/,(?=(?:(?:[^\'\"]*(?:\"|\')){2})*[^\'\"]*$)/';
$str = '1,"2,2,2",three,\'four, 4\',,"6\\tsix"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);