import re
regex = re.compile(r"F\[(?:[^\[\]]+|\[(?:[^\[\]]+|\[[^\[\]]*\])*\])*\]", flags=re.MULTILINE)
test_str = ("let txt = F[aaa( F[ccc( F[ddd(3,3,3)],2,2)],0,0)] otra texto F[bbb(1,1,1)]\n"
"let txt = F[aaa( F[ccc(2,2,2)],0,0)] otra texto F[bbb(1,1,1)]\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")