$re = '/foo\d+.*/m';
$str = 'foo1.bar
foo2.bar
foo10.bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);