# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:Expiration Fee: )?(\d+)\s+((?:[a-zA-Z\d\/]+\s+)*)(?:\(([a-zA-Z]+)\)\s+)?(?:>([0-9.]+)\s+)?(?:([\d.]+-[\d.]+)\s*)?(?:\((\d{1,2}(?::\d{2})?[AP]M)\)\s+)?(?:@\s+([\d.]+))?"
test_str = ("Expiration Fee: 10 LONG AUD/USD >.8189 (9:50AM) @ 90.5\n"
"10 Wall St 30 (Mar) >17900 (4:15PM) @ 69.5\n"
"2 AUD/USD >.8114 (11:35AM) @ 97.5\n"
"Expiration Fee: 1 SHORT AUD/USD >.8114 (11:35AM) @ 87\n"
"2 Wall St 30 (Mar) 18000-18100 (12PM) @ 18023\n"
"2 LONG US Tech 100 (Mar) >4284 (1:15PM) @ 56.5\n"
"1 EUR/USD >1.2180 (3PM) @ 41.5\n"
"Expiration Fee: 1 SHORT AUD/USD >.8114 (11:35AM) @ 87\n"
"Expiration Fee: 1 LONG GBP/USD >1.5090 (8:55PM) @ 95.5\n"
"Expiration Fee: 2 SHORT US 500 (Mar) >2037.7 (10AM) @ 5.5\n"
"Expiration Fee: 1 SHORT EUR/USD >1.1582 (2:20PM) @ 11.5\n"
"6 SHORT GBP/USD >1.5200 (3:10PM) @ 22.3333\n"
"Expiration Fee: 1 SHORT GBP/USD >1.5085 (8PM) @ 17.5\n"
"Expiration Fee: 1 SHORT EUR/GBP >.7340 (3PM) @ 33.25\n"
"2 Wall St 30 (Mar) 18000-18100 (12PM) @ 18023\n"
"Expiration Fee: 5 LONG US Tech 100 (Mar) 4190-4390 (4:15PM) @ 4291\n"
"2 LONG Wall St 30 (Mar) >18000 (1:15PM) @ 53.5\n"
"1 AUD/USD .7570-.7670 (2PM) @ 0.7626\n"
"1 US 500 (Jun) 2075.0-2085.0\n"
"1 US 500 (Jun) 2075.0-2085.0 (1PM) @ 2079\n"
"1 AUD/USD .7570-.7670 (2PM) @ 0.7626\n"
"2 AUD/USD .8020-.8220 (11PM) @ 0.8118")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.