$re = '/^(?!.*(.)\1+).*$/m';
$str = '12345
a11145
aaa664';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);