$re = '/\b(\d+)\b(?=.*\b\1\b)/m';
$str = '59, 5, 53, 53, 545, 55, 545, 56, 5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);