const regex = /Current File:[ \t]*(\S+\.txt)[^O]*(?:O(?!ld File)|[^O])+ Old File:[ \t]*(\S+\.txt).*(?:\r?\n(?!--).*)*(?=\r?\n--)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Current File:[ \\t]*(\\S+\\.txt)[^O]*(?:O(?!ld File)|[^O])+ Old File:[ \\t]*(\\S+\\.txt).*(?:\\r?\\n(?!--).*)*(?=\\r?\\n--)', 'gm')
const str = `Current File: week-28\\gcweb.txt (=>) ########## Old File: week-27\\gcweb.txt (<=)
2019-07-21 13:20:42 ip-172-17-3-71=>
2019-07-17 13:27:12 ip-172-17-3-71<=
--------------------------------------------------
--------------------------------------------------
Current File: week-28\\gcckup.txt (=>) ########## Old File: week-27\\gcckup.txt (<=)
2019-07-21 13:20:46 ip-172-17-2-101=>
2019-07-17 13:27:14 ip-172-17-2-101<=
--------------------------------------------------
--------------------------------------------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}