$re = '/^\((\d+)(?=\))/m';
$str = '(123)abc
defg(456)
hijkl
(999)
7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);