import re
regex = re.compile(r"\b(access.log|osm_ms01.log|osm_ms01-diagnostic.log)\b", flags=re.MULTILINE)
test_str = ("```\n"
"-rw-r----- 1 osm_user osm_user 51200310 Dec 2 15:55 osm_ms01.log00025\n"
"-rw-r----- 1 osm_user osm_user 51200201 Dec 2 19:52 osm_ms01.log00026\n"
"-rw-r----- 1 osm_user osm_user 51200010 Dec 2 23:49 osm_ms01.log00027\n"
"-rw-r----- 1 osm_user osm_user 1251657 Dec 3 02:53 osm_ms01.out00098\n"
"-rw-r----- 1 osm_user osm_user 14534 Dec 3 03:23 osm_ms01.out00099\n"
"-rw-r----- 1 osm_user osm_user 2124021 Dec 9 00:42 access.log\n"
"-rw-r----- 1 osm_user osm_user 3406259 Dec 9 00:44 osm_ms01.out00100\n"
"-rw-r----- 1 osm_user osm_user 14632 Dec 9 00:55 osm_ms01.out00101\n"
"-rw-r----- 1 osm_user osm_user 4142712 Dec 9 01:00 osm_ms01-diagnostic.log\n"
"-rw-r----- 1 osm_user osm_user 51200768 Dec 9 13:20 osm_ms01.log00028\n"
"drwxr----- 2 osm_user osm_user 4096 Dec 11 00:58 metrics\n"
"-rw-r----- 1 osm_user osm_user 1101990 Dec 11 01:38 osm_ms01.out\n"
"-rw-r----- 1 osm_user osm_user 1150229 Dec 11 01:38 osm_ms01.log\n"
"```")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")