re = /(https?:\/\/)?([\da-z\.-]+)\.([a-z\.]{2,6})([\/\w# \.-]*)*\/?$/
str = 'google.com/#my/rege'
# Print the match result
str.match(re) do |match|
puts match.to_s
end