$re = '/"[^"]+"/';
$str = 'gmail.com. 300 IN TXT "v=spf1 redirect=_spf.google.com"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);