import Foundation
let pattern = #"ProcessChanges.*name=(.*)id=.*cardId=(\w+).*from (.*) -> (.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"[Zone] ZoneChangeList.ProcessChanges() - id=33 local=False [name=Faceless Manipulator id=8 zone=HAND zonePos=0 cardId=EX1_564 player=1] zone from FRIENDLY DECK -> FRIENDLY HAND "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}