$re = '/(((http|https):\/{2})+(([0-9a-z_-]+\.)+([0-9a-z_-]+)(:[0-9]+)?((\/([~0-9a-zA-Z\#\+\%@\.\/_-]+))?(\?[0-9a-zA-Z\+\%@\/&\[\];=_-]+)?)?))/ium';
$str = 'http://subdomain.google.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);