$re = '/(?!\S*S)\b\S+\b/';
$str = 'Sally Desk
Camp Silly
Not Bad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);