import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=name=\")[^\"]*";
final String string = "<outputColumn id=\"426\" name=\"Net Salary per month € (3rd Applicant)\" description=\"\" lineageId=\"426\" precision=\"0\" scale=\"0\" length=\"255\" dataType=\"wstr\" codePage=\"0\" sortKeyPosition=\"0\" comparisonFlags=\"0\" specialFlags=\"0\" errorOrTruncationOperation=\"Conversion\" errorRowDisposition=\"FailComponent\" truncationRowDisposition=\"FailComponent\" externalMetadataColumnId=\"425\" mappedColumnId=\"0\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}