re = /(?<!\d)\s+|\s+(?!\d)/i
str = 'Rama 1 * 2.34 * ( L - 0.45 ) XYZ 10 20.05 30.06 40 P > 25.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result