$re = '/<button *((?!analytics).)*<\/button>/m';
$str = '<button> </button>
<button truc=bildule> </button>
<button analytics> </button>
<button analytics truc bidule> </button>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);