#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?:fixed ?|finished ?|complete ?)?#\K\d{1,16}"
Local $sString = "I made a commit [#12345678] to a story" & @CRLF & _
"[finished #12345678] Made a commit" & @CRLF & _
"[fixed #12345678] Made a commit" & @CRLF & _
"[complete #12345678] Made a commit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")