package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:www\.|(?:https?|ftp|news|file):\/\/)[-A-Z0-9+&@#\/%?=~_|!:,.;]*[-A-Z0-9+&@#\/%=~_|]`)
var str = `bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3 www.peckale.com/#!contact/c11m6, www.peckale.com/#!contact/c11m6!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}