$re = '/(?<=[]A-Z])(\d+)(?=[A-Z])/';
$str = 'A123B456C798
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);