import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(magnolia\\.develop)(s*=s*)(.+)";
final String string = "#--------------------------------------------\n"
+ "# Here we define some properties not\n"
+ "# configured in the config repository.\n"
+ "# They are used in common before the initialization\n"
+ "# of the repositories.\n"
+ "#\n"
+ "# WARNING: on Windows systems, either use the /\n"
+ "# to separate path elements, or escape the \\ with\n"
+ "# another \\, i.e C:\\\\magnolia\\\\data\\\\repositories\n"
+ "# or c:/magnolia/data/repositories\n"
+ "#--------------------------------------------\n"
+ "magnolia.home=${magnolia.app.rootdir}\n"
+ "# The directory to expose file system resources from\n"
+ "magnolia.resources.dir=${magnolia.home}\n"
+ "# Pattern to define which resources should be observed by ClasspathScanner\n"
+ "magnolia.resources.classpath.observation.pattern=.*\\\\.(ftl|yaml)$\n"
+ "# Directories relative to magnolia.resources.dir which will be excluded from FileResourceOrigin observation.\n"
+ "# Also see info.magnolia.resourceloader.file.FileSystemResourceOrigin#EXCLUDED_DIRECTORIES\n"
+ "#magnolia.resources.filesystem.observation.excludedDirectories=META-INF,WEB-INF,cache,docroot,logs,repositories,tmp\n"
+ "magnolia.cache.startdir=${magnolia.home}/cache\n"
+ "magnolia.upload.tmpdir=${magnolia.home}/tmp\n"
+ "magnolia.exchange.history=${magnolia.home}/history\n"
+ "magnolia.repositories.config=WEB-INF/config/default/repositories.xml\n"
+ "magnolia.repositories.home=${magnolia.home}/repositories\n"
+ "magnolia.repositories.jackrabbit.config=WEB-INF/config/repo-conf/jackrabbit-bundle-derby-search.xml\n\n"
+ "log4j.config=WEB-INF/config/default/log4j.xml\n"
+ "magnolia.logs.dir=${magnolia.home}/logs\n\n"
+ "# The directories in which the bootstrap files are searched\n"
+ "magnolia.bootstrap.dir=WEB-INF/bootstrap/author WEB-INF/bootstrap/common\n\n"
+ "# This is only used for the initial installation afterward the configuration in the config repository is used\n"
+ "# The value is saved in /server/admin\n"
+ "magnolia.bootstrap.authorInstance=true\n\n"
+ "# Some modules contain optional sample content. They will check this property to decide if they should install\n"
+ "# the sample data\n"
+ "magnolia.bootstrap.samples=true\n\n"
+ "# Activate UTF-8 support to pages\n"
+ "magnolia.utf8.enabled=false\n\n"
+ "# Switch to false to enhance the performance of the javascript generation and similar\n"
+ "magnolia.develop=false\n\n"
+ "# Change to point at your custom Vaadin widgetset and theme\n"
+ "# Your widgetset should always inherit magnolia's default widgetset (info.magnolia.widgetset.MagnoliaWidgetSet)\n"
+ "# Your theme should always include magnolia's default theme (admincentral)\n"
+ "magnolia.ui.vaadin.widgetset=info.magnolia.widgetset.MagnoliaWidgetSet\n"
+ "magnolia.ui.vaadin.theme=admincentral\n\n"
+ "# Contact details displayed in the footer of the login form\n"
+ "#magnolia.service.contact=\n\n"
+ "#--------------------------------------------\n"
+ "# Repository connection\n"
+ "#--------------------------------------------\n"
+ "magnolia.connection.jcr.userId = admin\n"
+ "magnolia.connection.jcr.password = admin\n\n"
+ "# Set it to true if bootstrapping/update should be performed automatically\n"
+ "magnolia.update.auto=false\n\n"
+ "# Location of the file containing both the private and the public keys used to verify authenticity of activation requests\n"
+ "# This file is generated if not present\n"
+ "magnolia.author.key.location=${magnolia.home}/WEB-INF/config/default/magnolia-activation-keypair.properties\n";
final String subst = "$1$2true";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}