package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<if>(.*?)<\/if>`)
var str = `Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut<if>abc</if> laoreet dolore magna aliquam erat volutpat. Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl ut aliquip ex {{test}}ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse<if>123</if> molestie consequat, vel {{test}} illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim qui blandit praesent luptatum zzril delenit augue duis dolore te feugait nulla facilisi.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}