$re = '/([A-Z][a-z]*)((?=[A-Z][a-z]*|\b)|\d+)/';
$str = 'C3H20IO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);