re = /category\/(.+)\/(?(?=(?:category)\/)^|(.+))\/(.+)\/?$/m
str = 'http://domain.com/projects/category/print/page/2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end