$re = '/(.+)(?:\1)+$/m';
$str = '1.333
1.5444
1.123123
1.5432121212
1.321
1.44212';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);