package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[][a-zA-Z0-9()]+$`)
var str = `abd
[abcdef]
this one not (spaces!)
neither!this!one
123butthis][]][][]][]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}