$re = '/^(?!(?:[^d]*\?d){8}$).*$/m';
$str = '?d?u?d?u?d?u?d?d?d?d?d
?d?d?d?d?u?d?d?d?d?u?d?
d?l?u?d?d?d?d?d?d?d?d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);