re = /(?<=[a-zA-Z0-9])'(?=[a-zA-Z0-9])/
str = 'Jane\'s book
\'apples\',\'oranges\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end