$re = '/\/PrimoLivello(\/|$)[a-zA-Z]*/';
$str = '/PrimoLivello
/PrimoLivello/SecondoLivello
/PrimoLivello/SecondoLivello/Terzo
/
/PrimoLivello
/SecondoLivello';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);