import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)\\s{6,}([A-Z ]+)\\s+([0-9\\.]+)\\s+([0-9\\.]+)\\s+([0-9]+)";
final String string = "43034452 LONGSHIRTPAIETTE 17.30\n"
+ " 27.90 \n"
+ " 0110 \n\n\n"
+ " COLOR : : : : :\n"
+ " : : : \n"
+ " -11 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0\n"
+ "43034453 LONG SHIRT PAI ETTE 16.40\n"
+ " 25.90 \n"
+ " 0110 \n\n\n"
+ " COLOR : : : : :\n"
+ " : : : \n"
+ " -3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0\n"
+ "43034454 BASIC 4.99\n"
+ " 8.90 \n"
+ " 0110 \n\n\n"
+ " COLOR : : : : :\n"
+ " : : : \n"
+ " -5 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0";
final String subst = "\\1;\\2;\\3;\\4;\\5";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}